Our service can be used and viewed on all modern browsers, including Chrome, Firefox, Safari, Edge, etc.

These are supported browser

  • Edge 79+

  • Chrome 67+

  • Firefox 60+

  • Safari 11.3+

  • iOS Safari 11.3+

  • Android 7.0+

We do not support Internet Explorer as it is extremely outdated and does not support modern web code.

These are NOT supported browser

  • Internet Explorer (all versions)

  • Chrome < 67

  • Edge < 79

  • Firefox < 60

  • Safari < 11.3

  • iOS Safari < 11.3

  • Android < 7.0

Did this answer your question?